Bugs I'm having trouble with

I can’t seem to find the bugs sub category so I figured I would post one. I’m playing on an Android device and the first box that pops up when you first start is to show you what the icons mean etc. I can’t click through the pages and it caused my tab to crash. I reloaded the page and the box disappeared so I carried on, chose mining, bought a laser and reactor and went to ship loadout. I clicked on the mining box and it brings up the laser but I click equip and it doesn’t move the laser to my equipped box. Same with the reactor so I’m having some basic troubles progressing so far.

I have added you to the PT Alpha group, and moved the bug report to the correct area.

I do not have an android device unfortunately, so cannot test at this time. I will see if I can lay my hands on one so that I can run through your issues.

I crated a hauler and had the tab crash from the introduction box again so I’m able to replicate it. Same with equipping a cargo expander, it won’t equip. And another thing, I’m assuming based on the profession chosen it comes pre equipped with skills like level 1 hauling certification because it says I already have it but when I go to the list of cargo missions it says I need certification before I can accept any contracts.

Hi there Slurmwerds.

I have a Tab 2 Samsung Galaxy which is a cast off from my wife when she moved to an Ipad last year. I have powered it and updated the OS.

I can confirm that fitting items from the right in to a slot does not seem to work. Yet swapping an existing item does. Very strange.

On the pre installed browser (doesn’t seem to offer its name anywhere) I could play pretty much all the elements of the game, although it did have ‘some’ issues with a few of the pop up messages. Mostly I suspect because they appear near the screen break and render half on and half off the screen.

The hovers all seem to function and I managed some mining and hauling. All be it very slowly.

I installed Firefox and sadly that had some real issues on the tablet. The hovers refused to go away and the pop-ups rendered blank.

I can also confirm that the ‘initial’ help screen does lock up both browsers. But even more weird the help page in mining works fine.

I will make this tablet available to @prevuk so we can work through and see if there are any answers to some of these issues.

I will also try a few other browsers as I suspect its mostly down to the rendering engine of each browser.


Doing a little reading it would appear that javascript may not be enabled by default on android devices in the browsers. This may have changed very recently, but seems to have been an issue with android devices for some time.

Can you go into the settings on your browser (whichever one you use) and check javascript is enabled? I would expect to find the setting in an advanced area of browser settings, and should be a tick box.

Having spent some time this morning with the ageing old tablet I found that Chrome works a treat. I installed the standard chrome browser through the ‘Play Store’. I choose the normal version not the Dev or Beta.

Instantly it behaved more like a proper browser should. It resizes the screen to fit ‘Hooray!’ The fit / swap and remove functions work as they should and I played for 10/15 minutes testing all the elements. This included the Introduction blue box system when docked for the first time.

Mining, Hauling, Crafting, Refining, Recycling, Harvesters, and all the screens in-between worked as expected.

Even the Jump gate timer works (which doesn’t move on my Ipad) lol.

So the short version - Install Chrome to play PT. Please note I installed it and didn’t change any default settings.


Javascript is enabled, I use the standard browser, not firefox. I will install chrome and try it with that, thank you.

How did you get on Slurmwerds ?

Everything seems to work great with chrome, thanks! I also figured out you need to be docked to equip an item, which is a little odd. I don’t have a mouse to mouse over everything so some things take me longer to figure out :stuck_out_tongue:

Glad to hear that Chrome solved the issue. Sadly there is a lot of disparity between Mobile browsers (Phone and Tablet) and only a few are fairly close to being compliant.

Seems a few testers are not reading the text on the screen - your not alone :slight_smile: In the Ship Load out section on the right it warns you that you need to be docked to swap / fit items and docked at a Space Station to swap ships.

Remember this is not CE folks :slight_smile: Pretty much every space game I’ve played makes you dock to swap ship load-out.


No hover menus, or searching required. The information is right there as soon as you enter the loadout screen in the right hand column: