Strange leveleling Quirk

System Nebraska
Location Asteroid F: NEB 1

Mining Malifinumore

Clicked log account/ Character Select While mining Process was Still active

21/07/15 09:37 »Dig out the bunting, cake and the Terran Brandy… has just gained a new level. They are now level 1

New Level!
Congratulations, you have just levelled to 1.

You have been awarded 5,000 IP to your global IP Pool.

Seems to trigger if i start the mining an asteroid process and then try to log out the toon

It is repeatable every time i do the above

Thanks for confirmation of this we had spotted it but were not sure if it was a fluke. We will have to investigate.


Just to add my own observations on this, as I’ve now had the same issue happen. It’s not if I change toons mid-mining, but if I’m sitting in an asteroid field at all and change toons - but only after I’ve leveled up at least once. So maybe something with the code that checks if you’ve leveled up is doing something weird?

Sitting in an asteroid field and changing characters didn’t seem to do anything, but since I just leveled up now this seems to happen each time I swap (I even get the level up pop-up window just before it switches).

Edit: Of course, now that I post this, the odd behavior stops, but I just wanted to note that I got this to happen even when I wasn’t actively mining when I switched.

Up front I will say that I did have this issue a few days ago and it appeared that my browser had a bit of an issue and was possibly reprocessing the level up code. Once i closed my browser and reopend it I could not replicate.

Then Droffy logged his issue : Which i can’t replicate.

Then Sinter logged his issue : Which I can’t replicate.

Can i ask you to both try again and see if you can come up with a replicable way to make it do it. As is seems an illusive issue atm.


I’ve spent the evening trying to replicate, but no consistent way to get it to happen. I’ve tried similar things to what I did the first time. It seemed to trigger at some point, as the same message showed in the ticker (but I didn’t notice it right away), but I haven’t found a way to get the same behavior in an obvious way.

As a further note from the first time, it did seem to trigger shortly after a proper level up, so I think you might be right about the browser reprocessing the level up code, as that was sort of my suspicion from the start. How/why it’s doing that I can’t seem to replicate, which I know is less than helpful :stuck_out_tongue:

Have to say also that it did first happen to me after a normal level up too

I will keep testing here myself today to see if we can narrow it down. Keep any thoughts, reports coming.


I can’t get it to happen every time, but I’ve definitely been able to trigger it multiple times. This time, I got a toon to just before a new level (2 xp away), then, while sitting in an asteroid field (don’t know if that effects it), I use the Character Select option from the side tab, and that seems to be the thing that triggers it. I can’t prove it, but I think it only happens when you have multiple toons.

I’ve tried returning straight back to the original toon, logging in as the other and back, and every combination of choosing toons that I can think of, and it’s triggered a few times but not in a way I can say definitively “I did this set of things and it happened.”

Will keep trying, but wanted to report that it happened just before a level up this time, but it still seems to be something with the level up checking code.

Edit: And just to add, it always happens upon clicking the “Character Select” button, that is, as I’m leaving a toon it will trigger, not as I’m logging back in. I just exited/entered on a single toon about a dozen times (using Character Select, not logging out), and it triggered perhaps 3 times or so, but somewhat randomly.


To update this bug, when what ever is being run it is inserting the level up message but is not carrying a valid ‘pid’ so the entry has no name.

But, it is inserting IP into the users ‘muid’. Once this is resolved I will rebalance current players IP pools based on their characters total levels.

I’ve tried several methods as suggested above but its now difficult to tell who’s causing the extra insert and processes now with three or four of us logged in at any one time.

I have added another check in the level up code, that “should” now resolve this issue.

Please do keep a close eye on it though, and if you spot any more inconsistencies, or rogue level messages (created by your character or another) please let me know.

This issue does not seem to have reared its head since I added the check yesterday. I have tried to replicate it without luck, and have seen no other messages in the footer.

I have now rebalanced the IP Pools to where they should be.

I am still monitoring though.

I have seen no further instances of the rogue message, so am calling this one resolved.