Freight "Mismatch"

Sometimes, when I choose a certain freight I get a red pop-up message that says something weird about mismatch and than I receive a completely different freight. Is this meant to be?

The only place this message appears is when you try to pick up a cargo load that you do not have the space to carry.

It will not pick up any load on this message.

I have only ever had this when i have tried to take more frieght then space. Tho i have never recieved a different freight in its place/

Negative Sir!

I had about 10 of these messages. At first I thought I made a mistake.
After that I thought this was a joke to give this game a random “bad event”, or that two players tried to pick up the same load at the same time.

I’m 100% sure the last time this happened I had an empty Freight.
Trying to load 55 Janisar Freight in Cronus, I got a Dumont load instead.
Fortunitely it was for another Cronus planet and the 55 Freight was still there to be picked up.
So I dropped the Dumont and after that succesfully picked up the Janisar 55 unit Freight

Please check Suzie Quatro toon for details around 1400 GT @ Cronus system.
Looks like a serious bug.

Also: On all occasions I got a load to drop somewhere. The message I get disappears quickly and says something about mismatch and “pig load (?)”

But on top of this all:
Is it a problem, when you managed to create a “random bad event” by accident?
If it doesn’t crash the game, it’s fun to adapt and overcome such an event.

There are only 3 messages in the game that mention mismatch. All 3 are in the freight offices, and only show IF the code to load freight has been bypassed as you have no space… it is absolutely impossible for a load to be placed in your ship… period! You are mistaken.

There are no messages in the game anything to do with pig load. The mismatch message mentions a square peg and a round hole, perhaps that is the one you see? If so, it has already gone past the section where it checks your cargo bay, decides you do not have space, so gives the message.

I have tried this many times, and simply cannot get any cargo bigger than my available space. Not sure how (if) you are managing it… ?

No, I’m not seeing ghosts. It happened far more than 3 times to me.
And yes it’s probaly the right message you described.

Check freight drops by Suzie Quatro on Cronus today to be sure.
The last received and dropped freight (so it gives freight) after Suzie jumped to Cronus was from the mismatch i got from trying to pick up 55 units from Janisar.
I think I needed to drop this freight at Sinofar or Rossini Dock

My freight cargo was empty, when this event happened. 100% sure.
Why would I try to pick up 55 at first, fail and succeed afterwards?

Next time, this happens I’ll try to log full details.

Maybe better to let it be for now, untill I can give more solid data, or confirmed by others.

I only got this event from Janisar freight, not from Dumont

OK, no worries… I will run through the same tests with Janisar and Dryden, see if I can replicate. If you do get it again though, please let me know, as it will definitely be a bug, and should not be worked around.

Is this the error that you are seeing? I just need to clarify before I go digging any further…

Yes, that’s the one I see popping up too often.

Just to add to this every time I get this message either by trying to add more than I have room for or accidentally doing the same I do NOT get any other cargoes. I get nothing added. Leaves me with the same space I expect to find.

If your organising the list by cargo size and get the message the list will auto reorder in the background. I suspect your seeing this change in mission orders and ‘assuming’ your getting a load.

At no time can I replicate getting a load when seeing the Square peg in a Round hole message.


Ok, I’ll assume I am wrong, but will continue with just Janisar loads from now.

Prime by all means hollar from the roof tops if you can still create cargoes from this process. All I’m saying is ‘I cant replicate it at this time’. It shouldn’t matter which offices you use as the code for all 3 is identical in it’s process.


Thanks Coops for the heads up. At the time I posted this I was 100% sure and you pointed out I could have fooled myself. That’s why I said I asume I could be wrong.

To be able to repeatt a 100% reproduction of this assumed bug, I descided to limit myself.
And when I take Dumont freight, I double check freight at all times to be sure.

Sofar no issues.

I think Coops’ analysis must be the most plausible. I must have tricked myself.